knackser bei SEND/RECIEVE

Warum funktioniert ein bestimmtes Modul nicht so, wie man es sich vorstellt? Hier kann man Dampf ablassen.

Moderator: herw

knackser bei SEND/RECIEVE

Beitragvon KlangRaum » Mo 14. Jan 2008, 15:32

kennt jemand den unschönen effekt, das send/recieve beim umschalten knackser erzeugen, auch wenn im entsprechenden zweig nur events die nichts zur direkten audiobearbeitung beitragen und schon gar keine audiosignale verarbeitet werden?
ich hab eine grössere schaltung mit modulationsmatrix und mittlerweile sehr vielen send/recieve, die cpu-auslastung liegt bei 20-30% (minimac G4). die knackser sind allerdings so unauffällig, das sie erst im FX-zweig zur bedeutung kommen und dort aufschaukeln- im delay/reverb wird daraus ein kurzes aber hörbares "krisseln"
mir ist das vorher noch nie aufgefallen, allerdings hatte ich auch noch nie eine so umfangreiche modulationsmatrix.... liegt es uU an der anzahl der verwendeten send/recieve?????

einen ähnlichen effekt gabs früher bei reaktor 2.x: die normalen switch (!!!!) haben die audioengine beim schalten immer für einen kurzen moment komplett (!!!) unterbrochen, dieser effekt war sogar noch deutlicher zu hören
Siggi Natur ? :mrgreen:
Benutzeravatar
KlangRaum
synth guru
 
Beiträge: 647
Registriert: Di 1. Aug 2006, 13:55

Re: knackser bei SEND/RECIEVE

Beitragvon herw » Mo 14. Jan 2008, 16:04

KlangRaum hat geschrieben:kennt jemand den unschönen effekt, das send/recieve beim umschalten knackser erzeugen, auch wenn im entsprechenden zweig nur events die nichts zur direkten audiobearbeitung beitragen und schon gar keine audiosignale verarbeitet werden?
ich hab eine grössere schaltung mit modulationsmatrix und mittlerweile sehr vielen send/recieve, die cpu-auslastung liegt bei 20-30% (minimac G4). die knackser sind allerdings so unauffällig, das sie erst im FX-zweig zur bedeutung kommen und dort aufschaukeln- im delay/reverb wird daraus ein kurzes aber hörbares "krisseln"
mir ist das vorher noch nie aufgefallen, allerdings hatte ich auch noch nie eine so umfangreiche modulationsmatrix.... liegt es uU an der anzahl der verwendeten send/recieve?????

einen ähnlichen effekt gabs früher bei reaktor 2.x: die normalen switch (!!!!) haben die audioengine beim schalten immer für einen kurzen moment komplett (!!!) unterbrochen, dieser effekt war sogar noch deutlicher zu hören

Beim Umschalten der Receive-Verbindung reagieren diese wie ganz normale Switches, das heißt eben mit dem von dir beschriebenen Krisseln, bzw. wenn man vor allem einen Halleffekt dahinterschaltet mit einem Knacken bis zum heftigsten Knall. Letzeres tritt vor allem dann auf, wenn beim Snapwechsel die Halldauer sich stark verändert. Da bei einer Modulationsmatrix (via Send-Receive) diese Effekte auftreten, gibt es nur die Möglichkeit, durch Relays die Modulationsverbindungen aufzubauen, was aber zu einer unübersichtlichen Matrix führt (Harfe) und natürlich nicht den unschätzbaren Vorteil hat, dass unbenötigte Audiozweige ausgeschaltet werden, sondern ständig aktiv sind.
Ich habe das beim Hall etwas abdämpfen können, indem ich die Zuleitung zum Hall beim Snapwechsel mit Hilfe des Holdmoduls für ca. 0,3s ausschalte. Das ist ein Kompromiss, genügt aber im Normalfall.
Eine andere Möglichkeit, die ich schon seit längerem mit Gerald diskutiere, ist, beim Hall ein zweites Array gleicher Größe aufzubauen, so dass der "Knall" nicht im Hall potenziert wird, sondern ich eine frische "leere" Hallstrecke bekomme. D.h. ich wechsle bei einem Snapwechsel in ein "genulltes" paralleles Array. Leider habe ich das noch nicht realisieren können. In "Handexperimenten" habe ich das als wirksam nachweisen können. Ich habe lediglich das Problem, dass vor dem Snapwechsel das parallele Array genullt werden muss.
Sonstiges Knallen zwischen den Modulen kann man durch ein 1LP-Filter mit sehr niedriger Cutoff-Frequenz (5Hz) vermeiden. Warum das so ist, weiß ich nicht, aber es hilft ein wenig.
Wenn man die Snapwechsel vom Panel direkt durchführt, kann man mit ein wenig Logik "vor" dem eigentlichen Wechsel entsprechende Maßnahmen automatisch durchführen lassen. Beim Snapwechsel über die Instrumentenleiste hat man diese Möglichkeit leider nicht (Initialisierungsalgorithmus).
Benutzeravatar
herw
moderator
 
Beiträge: 3043
Registriert: Mo 13. Mär 2006, 19:28
Wohnort: Dortmund

Re: knackser bei SEND/RECIEVE

Beitragvon KlangRaum » Mo 14. Jan 2008, 16:27

herw hat geschrieben:...Beim Umschalten der Receive-Verbindung reagieren diese wie ganz normale Switches, das heißt eben mit dem von dir beschriebenen Krisseln, bzw. wenn man vor allem einen Halleffekt dahinterschaltet mit einem Knacken bis zum heftigsten Knall.....

im audioweg lasse ich mir das ja noch -wenn auch zähneknirschend- gefallen -aber nicht bei events(siehe beschreibung oben) und in einer ecke, die zb auf eine andere tabelle mit events schaltet und audio nicht weiter beeinflusst....

bei audiosignalen entspricht es der logik, das man nur im nulldurchgang störungsfrei schalten kann -uU kann man das durch schnelles kurzzeitiges dämpfen in den griff kriegen....

aber ich hab den eindruck als würde sich reaktor beim umschalten auf eine andere send-source zu einer art "kurzen, knacksenden denkpause" verabschieden um dann (ich vermute) hinterher nicht mehr so ganz samplesyncron weiter zu machen......... so ähnlich war es zumindest bei r2.x
Siggi Natur ? :mrgreen:
Benutzeravatar
KlangRaum
synth guru
 
Beiträge: 647
Registriert: Di 1. Aug 2006, 13:55

Re: knackser bei SEND/RECIEVE

Beitragvon herw » Mo 14. Jan 2008, 16:56

KlangRaum hat geschrieben:
herw hat geschrieben:...Beim Umschalten der Receive-Verbindung reagieren diese wie ganz normale Switches, das heißt eben mit dem von dir beschriebenen Krisseln, bzw. wenn man vor allem einen Halleffekt dahinterschaltet mit einem Knacken bis zum heftigsten Knall.....

im audioweg lasse ich mir das ja noch -wenn auch zähneknirschend- gefallen -aber nicht bei events(siehe beschreibung oben) und in einer ecke, die zb auf eine andere tabelle mit events schaltet und audio nicht weiter beeinflusst....

bei audiosignalen entspricht es der logik, das man nur im nulldurchgang störungsfrei schalten kann -uU kann man das durch schnelles kurzzeitiges dämpfen in den griff kriegen....

aber ich hab den eindruck als würde sich reaktor beim umschalten auf eine andere send-source zu einer art "kurzen, knacksenden denkpause" verabschieden um dann (ich vermute) hinterher nicht mehr so ganz samplesyncron weiter zu machen......... so ähnlich war es zumindest bei r2.x
Ich weiß nicht wie groß Deine Modulationsschaltung ist, aber probiere zunächst erstmal die Latenz ein klein wenig zu erhöhen. Es könnte sein, dass beim Umschalten Reaktor neu kompiliert (in der CPU-Anzeige sieht man kurzzeitig einen orangenen Balken von links nach rechts wandern). Bei Latenzerhöhung zum Beispiel von 4ms auf 6ms oder ähnlich, geht das weg.
Benutzeravatar
herw
moderator
 
Beiträge: 3043
Registriert: Mo 13. Mär 2006, 19:28
Wohnort: Dortmund

Re: knackser bei SEND/RECIEVE

Beitragvon KlangRaum » Mo 14. Jan 2008, 23:05

danke für den tip, daran hab ich gar nicht mehr gedacht, es scheint wirklich daran zu liegen. die latenz war auf 7 ms, aber ich werd gleich mal damit experimentieren....
habs probeweise mal hammerhart hochgesetzt und werd jetz mal alle möglichen schaltungen durchgehen und mal schauen bei welchem wert es wieder auftaucht.

nachtrag:
anscheinend muss es in meinem fall um die 20ms liegen....
HERW.... betrachte dich als geküsst :mrgreen:

Ich weiß nicht wie groß Deine Modulationsschaltung ist

....mittlerweile riesig.... ist ne art modular mit sequencer, bei dem ich multitimbrale klangerzeugung ausprobiere: einzelne voices werden unterschiedlich geroutet. mal sehn, wie weit ich komme bis ich den durchblick verliere und zum arzt muss.... ;)
hier -bei diesem projekt- kommen auch die filter mit dem overdrive zum einsatz. klanglich ist das schon jetzt ne ziemliche rappelkiste, die wohl am liebsten goa-styles aus den boxen schiebt. wenn ich einige kleinere probs beseitigt hab und die remotegeschichten funzen, werd ich mal ein tapemodul dranhängen und ein demo machen ;)
Siggi Natur ? :mrgreen:
Benutzeravatar
KlangRaum
synth guru
 
Beiträge: 647
Registriert: Di 1. Aug 2006, 13:55

Re: knackser bei SEND/RECIEVE

Beitragvon herw » Di 15. Jan 2008, 08:21

KlangRaum hat geschrieben:da...
nachtrag:
anscheinend muss es in meinem fall um die 20ms liegen....
...

20 ms, das finde ich nicht akzeptabel, das ist ja deutlich hör- und fühlbar. Kannst Du nicht irgendwie auf 10 ms reduzieren?

ciao herw
Benutzeravatar
herw
moderator
 
Beiträge: 3043
Registriert: Mo 13. Mär 2006, 19:28
Wohnort: Dortmund

Re: knackser bei SEND/RECIEVE

Beitragvon KlangRaum » Di 15. Jan 2008, 12:17

ich werd mal sehn, wie ich das noch weiter drücken kann, da ist noch einiges nicht optimiert btw prophylaktische baustelle. trotzdem ists schon toll, das die cpulast mich noch nicht abwürgt...
vermutlich muss ich mich doch dazu durchringen die schaltmatrix zu begrenzen. derzeit kann man beliebig audio oder events durchjagen, was natürlich ziemliche flexibilität bezüglich der modulationsmöglichkeit mitbringt, mal sehn....
ziel bleibt, das es auch auf meinem älteren minimac ohne einschränkungen läuft
Siggi Natur ? :mrgreen:
Benutzeravatar
KlangRaum
synth guru
 
Beiträge: 647
Registriert: Di 1. Aug 2006, 13:55


Zurück zu KERNSCHMELZE

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron