Panik (all gate off) funzt nicht in Host

Fragen und Antworten, Beispiele

Moderator: herw

Panik (all gate off) funzt nicht in Host

Beitragvon Eventmanager » So 21. Jun 2015, 17:56

Ich habe ein Panik-Makro, es löpt süpi reaktor-intern (auch kabelfrei von Instrument zu Instrument).
Aber in nem Host verweigert es den Dienst (auch hier ist "intern" alles bestens, allerdings nicht wenn es als Midi-Master dient, das zu anderen tracks gerouted wird).
So schön simple siehts aus:

Bildschirmfoto 2015-06-21 um 15.37.11.png
Bildschirmfoto 2015-06-21 um 15.37.11.png (13.33 KiB) 1954-mal betrachtet

Ist es vielleicht zu schnell? Die ganze iteration benötigt wahrscheinlcih nicht mal eine Millisekunde. Und Midi wird ganz offensichtlich NICHT mit SR gesendet. Ist das Teil also zu schnell um dem Host die nötigen Daten zu übermitteln?

Wie bekomme ich nun das Teil dazu, das jedes neue Iteration-Event sagen wir eine Millisekunde nach dem anderen startet?
Ein simples hold reicht nicht und kaskadierte Delays will ich auf jeden Fall vermeiden. Clock, puls, Displayrate… scheinen mir ratsam, aber ich hab keinen Schimmer, wie ich die interne Iteration dazu „syncen“ kann.

Ich habe ürbrigens andere Versuche durch, mittels bspw. Button ein Gate-Off zu senden. Der Button sendet bspw. #51 (die aktuelle Note) und es funzt NICHT (auch reaktor.intern). Nutze ich hingegen einen Knob, der die Nummer "überfährt" funzt es manchmal, manchmal auch nicht. Es ist also AUSSERDEM eines dieser mysteriösen Non-Trigger-Bug-Probleme. Das Panik Makro als solches umschifft dieses Problem, es triggert zuverlässig, zumindest intern.
Eventmanager
meister
 
Beiträge: 178
Registriert: Di 25. Jun 2013, 16:26

Zurück zu MODULE UND MAKROS (primary level)

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron